Adobe Flash Player Security Update

by Andy on November 5th, 2010 in How to, Security Alert, Security Tips.

Critical vulnerabilities have been identified in Adobe Flash Player 10.1.85.3 and earlier versions for Windows, Macintosh, Linux, and Solaris, and Adobe Flash Player 10.1.95.1 for Android. These vulnerabilities, including CVE-2010-3654 referenced in Security Advisory APSA10-05, could cause the application to crash and could potentially allow an attacker to take control of the affected system.


Full Adobe advisory info here.


Affected software includes:


Flash Player 10.1.85.3 and earlier
Flash Player 10.1.85.3 and earlier - network distribution
Flash Professional CS5, Flash CS4 Professional and Flex 4
Flash CS3 Professional and Flex 3


Users are recommended to update to Adobe Flash Player 10.1.102.64 from Adobe's site.


Click here to see which version of Flash player is installed on your machine.